Beiträge von Samira

    Du kannst die Fragen auch per SQL exportieren und wieder importieren, wenn du die Kategorie-IDs auf die Zielumgebung anpasst oder alles genau gleich anlegst. Ich musste zwar die Umlaute anpassen, aber so habe ich meine Fragen auch von einer Umgebung auf die andere übertragen.


    Ist es dennoch aktuell oder bist du schon fertig?

    Erstellt man einen Forenbeitrag und fügt per BBCode eine Frage hinzu, wie ich das nun mache:


    FAQ: Welche Zahlungsmethoden werden angeboten?

    Derzeit biete ich PayPal, Kreditkarte (Stripe), Sofortüberweisung (Stripe), Giropay (Stripe) und Apple Pay (Stripe) als Zahlungsmethoden an.


    Dann werden Vorschaubilder von Dateianhängen nicht mehr dargestellt, obwohl man ihn im Editor und auch in der Vorschau sehen kann.



    Nach dem Absenden bleibt nur der Link stehen, wie es auch hier der Fall ist.

    Ich fände es gut, wenn man die Fragen per Drag an Drop sortieren könnte und nicht nur über die Nummern. So geht es im WSC ja an sich auch bei anderen zu sortierenden Einträgen. Das ist schon um ein vielfaches praktischer. Das sie nun unten angehängt werden ist aber natürlich auch schon toll. Wie ich gesehen habe, sind die nächsten Features aber nun geplant und da dachte ich, das wäre doch auch noch toll :) .

    Bin dann hergegangen und habe die Einträge via "Bearbeiten" wieder geöffnet

    und abgespeichert.

    Das hatte ich bei obiger FAQ1 auch gemacht und da ist gar kein BBCode drin. Auch das geht bei mir nicht.


    Och menno, ich will auch :D .


    Habe die Änderung wie auf GitHub eingefügt.

    Du hast also auch nur die zwei Dateien aktualisiert? Sonst gar nichts?

    https://github.com/tkirchDev/dev.tkirch.wsc.faq/pull/15


    Ich hab die zwei Dateien QuestionAction.class.php und FaqBBCode.class.php in meinem Testsystem überschrieben und danach noch den Cache übers ACP geleert und es ausprobiert. Nun wird im Posting gar nichts mehr angezeigt, aber auch kein Fehler ausgegeben.


    Der BBCode im FAQ Eintrag selber funktioniert, wenn man ihn neu speichert. Leider sind zwar alle FontAwesomeIcons weg, aber gut, dann muss man das eben nochmal einfügen.


    Der BBCode zum Einfügen in einen Forumpost funktioniert nun aber gar nicht mehr.



    Und nach dem Speichern sieht es so aus:



    Eine Fehlermeldung kommt nicht.


    Vielleicht fehlt noch irgendwas und die zwei Dateien reichen nicht?

    Ja, in die Frage einfügen geht und die Vorschau geht auch, aber wenn ich den BBCode nutze und das so einfüge wie hier


    FAQ: Welche Zahlungsmethoden werden angeboten?

    Derzeit biete ich PayPal, Kreditkarte (Stripe), Sofortüberweisung (Stripe), Giropay (Stripe) und Apple Pay (Stripe) als Zahlungsmethoden an.


    und da ist ein Icon drin, dann gibt es den Fehler. Ich bekomme das Thema dann gar nicht mehr im Forum geöffnet. Ich muss das [faq='1'][/faq] über die Datenbank aus den Posting löschen, damit das wieder klappt.


    Auch, wenn ich den Inline-Code BBCode in der FAQ benutze


    hier schreib ich mal was rein


    wird das bei mir nicht umgewandelt. Das bleibst so stehen:


    [tt]hier schreib ich mal was rein[/tt]


    Einen Fehler gibt es dabei aber nicht.

    Hallo zusammen,


    wenn ich eine Frage mit Font Awesome Icons aus diesem Plugin einbaue


    https://shop.softcreatr.com/product/25-font-awesome/


    und die dann über den BBCode in ein Posting einbinden will, bekomme ich schon in der Vorschau einen Exception Error.


    Im Fehlerprotokoll ist folgende Meldung zu finden:



    FAQs ohne Icons kann man super einbinden.